Общие сведения

Neat Image - программа цифровой фильтрации, предназначенная для уменьшения видимого шума в цифровых изображениях.

Шум является серьезной проблемой, мешающей высококачественной обработке цифровых изображений. В цифровой фотографии камеры потребительского и полупрофессионального уровня производят изображения с заметной шумовой компонентой.. Эта компонента становится особенно большой при переводе сенсора камеры в режим высокой чувствительности (больших ISO). Шум уменьшает визуальное качество изображений и отпечатков Некоторые операции по обработки изображений делают шумность изображений еще большей.

Neat Image определяет, анализирует и уменьшает шум в изображении. При этом качество фильтрации выше, чем у других методов, поскольку Neat Image учитывает специфические характеристики отдельного устройства, обеспечивая фильтрацию более аккуратной. Вы можете настроить программу для работы с почти любым источником изображения( цифровая камера, сканер и т.д.). Доступность богатого набора настроек позволяет легко достичь желаемого уровня понижения шума.

Дополнительно, Neat Image способен сделать изображения выглядящими более четко без падения качества (что обычно неизбежно для шумных изображений). Сочетание повышения резкости с понижением шума делает это возможным.

Смотрите примеры понижения шума Neat Image.

Neat Image доступна в 4 редакциях: Demo, Home, Pro and Pro+. Demo - свободная редакция с слегка ограниченной функциональностью. Home - редакция для домашних пользователей. Pro – редакция для профессионалов. Pro+ дополнительно включает в себя Photoshop-совместимую версию фильтра (плугин).


Возможности Neat Image

Уменьшение шума и повышение резкости изображений

· Продвинутый фильтр шума для уменьшения уровня шумов в цифровых изображениях.

· Полный контроль над установками фильтрации для получения желаемого уровня понижения шумов

· Интеллектуальный фильтр резкости для получения изображений выглядящих четче без повышения уровня шумов

· Поддержка 16-битных изображений для полного использования возможностей современных устройств

· Photoshop-совместимая версия plug-in

Профили устройств

· Широкий выбор свободных готовых к использованию профилей устройств в библиотеке профилей

· Легкое создание специфического профиля устройства для Вашей камеры или сканера

· Сопоставление профиля для автоматического сопоставления профиля устройства изображениям

Поточная обработка

· Поточная обработка серий изображений

· Фоновая обработка (изображения обрабатываются в тот момент, когда вы готовите новое изображение)

Предварительный просмотр

· Встроенный предварительный просмотр результатов обработки для выделенной области исходного изображения

· Предварительный просмотр результатов фильтрации для каждого цветового и частотного канала

· Выбор вариантов для более легкой настройки фильтра

· Полноразмерное сравнение оригинального и фильтрованного изображений

Некоторые возможности доступны не во всех версиях Neat Image. Детальная карта возможностей раскрывает отличия между редакциями Neat Image.


Системные требования

Рекомендованная конфигурация системы для обработки 2-3-мегапиксельных изображений:

· Windows 9x, ME, NT, 2000, XP

· Pentium-III или выше

· 128 MB RAM или выше

· True color display, resolution 1024x768 or more

Минимальные системные требования:

· Windows 95

· Pentium-I

· 32 MB RAM

· Hi-color display, resolution 800x600

Системные требования для практического использования Neat Image зависят от размера исходного изображения. Чем больше доступный размер системной памяти , тем большего размера изображения могут быть обработаны. Скорость обработки в основном определяется мощностью процессора и скоростью памяти.

Для не- plug-in версии Neat Image, исходные изображения должны быть в одном из следующих форматов (те же самые форматы поддерживаются для сохранения конечных изображений ***):

· TIFF (uncompressed, single image, no layers, no alpha channel, no mask)
- 24-bit RGB
- 48-bit RGB
- 8-bit grayscale
- 16-bit grayscale

· JPEG
- 24-bit RGB
- 8-bit grayscale

· BMP (uncompressed, Win3x)
- 24-bit RGB
- 32-bit RGB

Минимальный размер исходного изображения 20x20 точек; максимальный размер обычно ограничен объемом доступной системной памяти.

Plug-in версия фильтра поддерживается следующими пакетами:

· Adobe Photoshop 5, 6, 7, CS

· Adobe Photoshop Elements 2

· Jasc Paint Shop Pro 7, 8

· Ulead PhotoImpact 8

· Corel Photopaint

· PhotoLine32 9, 10

Plug-in может также быть совместим с другими пакетами.

*** Сохранение конечных изображений в форматы TIFF и BMP так же как и копирование в буфер обмена доступно только Home, Pro and Pro+ версиях Neat Image.


Когда это работает – типы исходных изображений

Neat Image создан для уменьшения шума, источником которого являются цифровые камеры, сканеры и другие источники изображений. Исходное изображение должно удовлетворять следующим требованиям:

· Шум должен быть равномерно распределен по изображению, т.е. не должно быть резкого роста уровня шума в отдельных областях или существенного изменения характеристик шума в изображении.

Neat Image прекрасно работает , например, на изображениях с шумом, вызванным большим ISO. Однако, «тепловые» и «битые» точки, вызванные повреждениями отдельных элементов сенсора, не удовлетворяют условию равномерности и, поэтому, не могут быть эффективно удалены Neat Image. Удаление тепловых точек стоит в планах разработки.

Другим распространенныv источником шума является JPEG-сжатие. JPEG–шум достаточно однороден при использовании высококачественной (high-quality) компрессии (низкой степени сжатия). Однако, при использовании низкокачественной компрессии (low quality), шум не является однородным. Поэтому мы рекомендуем использовать, по возможности, максимальное качество. Старайтесь избегать видимых артефактов («квадраты», вызванные JPEG-сжатием) в исходном изображении на ранних стадиях обработки изображения!

· Шум должен быть сконцентрирован в высоких и средних частотах. Это условие обычно выполняется на изображениях, полученных с современных камер, тем не менее оно может быть нарушено, если Вы используете большой (x2, x3 и более) уровень цифрового увеличения (digital zoom).

· Если Вы намерены использовать эквалайзер профиля, то сенсоры устройства должны быть RGB (в противовес сенсорам с субтрактивными цветами (subtractive primary colors)). Это требование не является жестким, и может быть опущено.


Overview of filtration process

Обзор процесса фильтрации

Вы можете отфильтровать изображение, используя Filtration Job Editor(редактор задания). Filtration Job Editor открывается, когда создается (автоматически или Вами) новое задание на фильтрацию. Когда Вы запускаете Neat Image самый первый раз, Filtration Job Editor открывается автоматически.

Используя Filtration Job Editor, Вы можете:

1) Открыть исходное изображение

- в окне просмотра выводится исходное изображение;

- информационная панель показывает данные об изображении;

2) Подготовить профиль устройства – анализ зашумленности необходим для фильтрации исходного изображения

- Вы можете выбрать готовый профиль
или
создать новый, на основании снимка;

- для создания нового профиля выберите лишенные деталей (там где содердится только шум) области изображенияt
И
предоставьте Neat Image анализировать их Rough Noise Analyzer (предварительным-грубым анализатором шума);

3) Измените настройки фильтра шума и резкости для получения желаемого уровня шумоподавления и повышения резкости

- Выберите любую область изображения и Neat Image подготовит предварительный просмотр;

- изменяйте настройки фильтра (начните с понижения шума в Y канале) и наблюдайте результат в предварительном просмотре;

- по достижении желаемого результата, переходите на следующий шаг;

4) Обработка исходного изображения

- примените фильтр к изображению в целом;

-когда процесс завершится, оцените результат обработки, сравнивая его с исходным изображением;

- сохраните конечное изображение в файл на диске.


Обработка примера с помощью Neat Image

Чтобы помочь Вам начать использовать Neat Image, мы подготовили пример. Вы можете загрузить его с веб-страницы Neat Image: пример для Neat Image (250KB). После загрузки, распакуйте архив в новую директорию.

Пример содержит файл изображения SampleImage.jpg. Это изображение – фрагмент типичного снимка, сделанного цифровой камерой (в примере Nikon CoolPix 950). Более подробная информация о снимке доступна в файле SampleImageInfo.txt.

Запустите Neat Image и, следуя пунктам ниже, наблюдайте, как программа может улучшить изображение:

1. Откройте изображение
- Нажмите [image] на панели инструментов закладки Input Image (исходное изображение):
- В диалоговом окне Open input image file (открыть файл исходного изображения), перейдите в папку, куда Вы распаковали пример, и двойным нажатием выберите файл SampleImage.jpg;

Neat Image откроет изображение.

Вы обнаружите, что изображение содержит много шума, особенно в области неба (используйте увеличение и прокрутку, чтобы увидеть это) Это типичный шум, производимый камерой Nikon CoolPix 950. Задача Neat Image – убрать этот шум. Для того, чтобы добиться этого, программе необходима информация о характере шума. Мы заранее подготовили такую информацию и сохранили ее в тестовом профиле устройства. Этот профиль расположен в файле SampleProfile.dnp. Используя профиль, Neat Image способен эффективно убрать шум из изображения..

2. Откройте пример профиля устройства
- Перейдите на закладку Device Noise Profile (профиль устройства);
- Нажмите [image] (голубой диск) в группе Device Noise Profile на правой панели;
- В диалоговом окне Open device noise profile (открыть профиль устройства), перейдите в папку, куда Вы распаковали пример, и двойным нажатием выберите файл SampleProfile.dnp;

Теперь профиль устройства открыт и Neat Image почти готов обработать изображение. Обычно, на этом этапе Вы изменяете настройки фильтра. Для того, чтобы помочь Вам начать работу в Neat Image, мы подготовили файл предустановой, хранящий ‘правильные’ настройки фильтра для изображения.

3. Откройте пример предустановок фильтра.
- Перейдите на закладку Noise Filter Settings (установки фильтра шума);
- Нажмите [image] (розовый диск) в группе Filter Preset (предустановки фильтра)на правой панели;
- В диалоговом окне Open filter preset (открыть предустановки фильтра), перейдите в папку, куда Вы распаковали пример, и двойным нажатием выберите файл SamplePreset.nfp;

Теперь предустановки загружены и настройки фильтра изменены для обработки изображения.

4. Применение фильтра.
- Перейдите на закладку Output Image (конечное изображение):
- Нажмите [image] (применить) на панели инструментов и ждите, пока не исчезнет индикатор прохождения процесса фильтрации.

Обработка может занять некоторое время (в зависимости от скорости процессора Вашего компьютера). Появится конечное фильтрованное изображение. Вы можете нажать на нем, для сравнения c исходным изображением. Заметьте, что шум (особенно в области неба) существенно уменьшился, при этом детали изображения сохранились.

Имейте в виду, что профили устройства и настройки фильтра, поставляемые в примере, подходят только для определенной камеры, работающей в определенном режиме. Neat Image способен выполнить аналогичное подавление шума на любом изображении, полученном с любого устройства, работающего в любом режиме. Для этого Neat Image необходим профиль этого устройства, описывающий характеристики шума этого устройства. Вы легко можете сформировать его самостоятельно с помощью Neat Image, поскольку программа автоматически формирует профиль при анализе выбранных вами фрагментов изображения. Также Вы можете найти готовые профили для многих камер и сканеров в секции Профили сайта Neat Image.

Главы Подробности процесса фильтрации и Создание профиля устройства содержат подробное описание процесса фильтрации и создания собственного профиля устройства. Также есть несколько примеров профилей и фильтраций в секции Примеры сайта Neat Image.


ШАГ I. Открытие исходного изображения

Используйте закладку Input Image (исходное изображение) в Filtration Job Editor(редактор задания):

Для открытия исходного изображения

Нажмите [image] (кнопка Open input image… - открыть исходное изображение) на панели инструментов, или [image] в Input Image (исходное изображение), или выберите пункт меню File | Open Input Image….

Поддерживаемые форматы файлов BMP, TIFF and JPEG (см. Требования).

или

Используйте буфер обмена Windows для помещения изображения из другой программы: используйте пункт меню Edit | Paste. Изображение в буфере обмена должно быть в формате RGB с глубиной цвета 24/32-бит.

или

Перетащите файл изображения из Windows Explorer (Проводник) в просмотр исходного изображения.

Когда исходное изображение получено, на панели Input Image (на правой панели) высветится относящаяся к изображению информация, такая как глубина цвета, размер, имена каналов и поля EXIF – данных (если доступны). Показываются только те поля EXIF , которые могут быть извлечены из исходного изображения и важны для понижения шума. Вам может понадобиться обратиться к этим данным позже.

Для прокрутки изображения в окне просмотра:

· Перетаскивайте изображение, используя среднюю кнопку мыши;

· Нажмите пробел и перетаскивайте изображение левой кнопкой мыши.

Для изменения уровня увеличения изображения:

· Используйте колесо прокрутки мыши;

· Используйте органы управления увеличением на панели инструментов;

· Используйте комбинацию клавиш Ctrl-Plus и Ctrl-Minus.


ШАГ II. Подготовка профиля шума устройства

Используйте закладку Device Noise Profile (профиль устройства) в редакторе задания Filtration Job Editor:

Для фильтрации изображения, Neat Image необходимо знать характеристики шума, производимого устройством – источником изображения (цифровая камера, сканер и т.д.). Шумовые характеристики устройства, работающего в определенном режиме, хранятся Neat Image в профиле устройства (device noise profile).

Существует несколько способов получения профиля устройства, соответствующего исходному изображению:

· Автоматически выбрать наиболее подходящий профиль из готового набора профилей, используя автосопоставление профилей Neat Image;

· Вручную Выбрать наиболее подходящий профиль из набора готовых, используя их описания;

· Создать новый профиль, используя исходное изображение или специально подготовленное тестовое изображение.

Первые две возможности присутствуют, если Вы имеете набор заранее подготовленных профилей. Вы можете найти свободные готовые наборы профилей для Вашего устройства:

· В разделе «Профили» сайта Neat Image;

· В разделе Профили устройств форума Neat Image;

· На других форумах, посвященных цифровым изображениям, и Web- страницах пользователей Neat Image.

При наличии набора профилей для различных режимов работы устройства, Вы можете (автоматически или вручную) выбрать профиль, соответствующий исходному изображению.

Если Вы не можете найти готовый набор профилей, но Вы можете легко создать профили самостоятельно. Для подробностей, смотрите главу Создание шумового профиля устройства.

Для автоматического выбораи открытия наиболее подходящего профиля

· Нажмите [image] (кнопка Profile matcher (сопоставитель профиля)) или выберите пункт меню Profile | Open Best Matching Profile.

Автосопоставление профиля Neat Image использует данные из полей EXIF исходного изображения для поиска наиболее подходящего для данного режима работы устройства профиля. Профиль устройства выбирается среди набора профилей, располагающихся в заданной папке ( и ее подпапках). Вы можете установить эту папку в опциях программы.

За подробностями обращайтесь к разделу Опции сопоставления профиля , где детально описаны опции: Matching device noise profile folder/directory(директория профилей), Matching parameters priorities (приоритет параметров сопоставления) и Auto match on image open(автоматическое сопоставление профиля при открытии).

Для ручного выбора и открытия профиля устройства

· Нажмите [image] (кнопка Open device noise profile… (открыть профиль устройства), голубой диск) в группе Профиль устройства (Device Noise Profile) или выберите пункт меню Profile | Open… . В диалоговом окне Open device noise profile (Открыть профиль устройства) Вы можете определить имя открываемого профиля устройства.

или

Выбрать профиль, используя всплывающее меню: нажмите кнопку справа от имени профиля в верхней части группы Профиль устройства (Device Noise Profile) и выберите профиль из всплывшего меню (если меню не появится, проверьте опции папок Neat Image).

Для поиска профиля, соответствующего режиму устройства, используйте имена файлов и структуру каталогов. Для более подробной информации о структурировании набора профилей, смотрите Подготовка набора профилей для различных режимов устройства.

Для создания профиля на основе исходного или тестового изображения

Если исходное изображение имеет достаточное количество лишенных деталей областей, или Вы имеете подготовленное тестовое изображение ( см. Использование калибрационной мишени), то Вы можете создать новый профиль устройства на основании этого изображения. Для более подробной информации обращайтесь к разделу Создание профиля устройства для отдельного режима.


ЩАГ IV. Применение фильтра к исходному изображению

Используйте закладку Конечное изображение (Output Image) в Filtration Job Editor:

Для того, чтобы применить фильтрацию к исходному изображению

1. Выберите тип конечного изображения.

Выберите тип конечного изображения из списка в Filter Output (Выход фильтра) (24-bit RGB/48-bit RGB; 8-bit/16-bit Grayscale). Тип конечного изображения может отличаться от типа исходного. В этом случае исходное изображения при фильтрации будет преобразовано.

2. Примените фильтрацию.

Нажмите [image] (кнопку Apply) на панели инструментов или выберите пункт меню Filter | Apply.

Процесс фильтрации может занять несколько минут (зависит от скорости процессора Вашего компьютера и размера изображения). На этот период Вы можете минимизировать окно Filtration Job Editor.

О скорости обработки

Neat Image – программа интенсивно использующая центральный процессор, и, в текущей реализации, скорость процессора наиболее критична. На Pentium IV 1.4GHz, обработка 2-мега пиксельного изображения занимает около 20 секунд (Neat Image v3.0). На компьютере с типичной конфигурацией, время обработки линейно зависимо от размера изображения (в мега пикселях).

3. По завершении фильтрации, Вы можете сравнить исходное и конечное изображении. Нажмите [image] (Кнопка Compare - сравнить) на панели инструментов или просто нажмите на конечном изображении. Если результат фильтрации неудовлетворителен, вернитесь на ШАГ III. для изменения настроек фильтра или на ШАГ II, для создания нового или улучшения текущего профиля, лучше соответствующего характеру шума исходного изображения.

Смотрите Опции Фильтрации для детального описания опций Neat Image, относящихся к фильтрации: Звуковой сигнал and Приоритет процесса фильтрации.


ШАГ V. Сохранение конечного изображения

Используйте закладку Output Image (Конечное изображение) в редакторе задания на фильтрацию( Filtration Job Editor):

Для сохранения конечного изображения

Нажмите [image] (кнопка Save output image as... (сохранить конечное изображение как…)) на панели инструментов или выберите пункт меню File | Save output image as….

Доступные форматы конечного файла: BMP, TIFF, и JPEG (см. Системные требования). Когда Вы сохраняете конечное изображение в формате JPEG, Вы можете выбрать качество сжатия. Последнее использованное значение качества сжатия будет использоваться по умолчанию до тех пор, пока Вы не измените его при сохранении конечного изображения в формате JPEG.
или

Используйте буфер обмена Windows для экспорта результатов фильтрации в другое приложение. Для этого используйте пункт меню Edit | Copy. Изображение, помещенное в буфер обмена имеет формат 24bit RGB.


Создание профилей устройства

Каждый профиль устройства описывает свойства шума, производимого устройством, работающим в некотором режиме. Набор профилей устройства соответствующий различным режимам работы составляет набор, который может быть использован для обработки изображений, полученных в любом из этих режимов.

В этой главе Вы найдете как создать одиночный профиль устройства, как документировать этот профиль для будущего использования, как подготовить и документировать структурированный набор профилей для Вашего устройства.

Создание профиля устройства для отдельного режима работы устройства

Использование тестовых изображений

Методы анализа

Подготовка набора профилей для различный режимов устройства


Создание профиля устройства для отдельного режима работы

Создание одиночного профиля устройства для режима работы включает в себя грубый (rough) и точный (fine-tuning) анализ шума. Грубый Анализ используется для начального анализа шума в изображении. Он подготавливает грубый профиль шума устройства. Точный анализ уточняет начальный анализ для получения точного профиля шума устройства.

Как грубый, так и точный анализы нуждаются в равномерных областях изображения для измерения характеристик шума. Если изображение содержит области, содержащие шум и в которых отсутствуют видимые/ важные детали, то Neat Image может анализировать свойства шума на этих областях. Neat Image самостоятельно не в состоянии найти однородные области или области не содержащие деталей важных для Вас, поэтому Вы должны определить области, которые программа должна проанализировать.

Используйте закладку Device Noise Profile (профиль устройства) в Filtration Job Editor(редактор задания):

1. Подготовка грубого профиля устройства

Для создания грубого профиля

1. Выберите рабочее цветовое пространство.
Используйте список рабочих цветовых пространств (Working color space) в группе Device Noise Profile (профиль устройства).

Рабочее цветовое пространство – внутренний параметр алгоритма фильтрации. Изображение переводится в рабочее цветовое пространство только на время обработки (исходное и конечное изображения всегда находятся в пространстве RGB).

Мы рекомендуем использовать YCrCb JPEG или YCrCb Symmetric пространства для анализа и обработки цветных изображений. Пространство RGB не является лучшим выбором для распознавания деталей, скрытых шумом. Его использование, скорее всего, не приведет к лучшим результатам.

Обычно, используются YCrCb JPEG (по умолчанию) пространство для цветных изображений или YCrCb Symmetric для черно-белых (полутоновых). Пространство RGB также может быть полезно в отдельных случаях. Например, если Ваша цель отфильтровать только один отдельный канал цвета (R (красный), G(зеленый) или B(синий)) изображения, тогда используйте пространство RGB.

Для использования каждого отдельного пространства, Вам необходим профиль, созданный в этом пространстве. Neat Image потребуется пересоздание профиля в случае, если Вы измените рабочее цветовое пространство

2. Поиск однородных областей изображения.

Просмотрите все изображение (с помощью прокрутки и увеличения) для поиска однородных областей.

В качестве однородной области (с малыми изменениями во всех каналах) может выступать облачное небо, чистое небо (без облаков и птиц) или любая другая часть изображения, с отсутствующими визуально заметными деталями (за исключением вызванных шумом).

Смотрите примеры однородных областей изображения.

Лучше всего (хотя и не обязательно), чтобы однородная область была серой (нейтральной). Размер области должен быть не менее 60x60 точек. Это минимальный размер, рекомендуемый 100x100 точек или больше.

Используйте [image] (кнопка Show negative (показать негатив)) на панели инструментов для временной инверсии изображения В некоторых случаях это может помочь найти однородные, содержащие только шум области.

Если Вам не удалось найти однородную область на исходном изображении, то Вы можете использовать альтернативное, тестовое, изображение. Предполагается, что тестовое изображение сделано этой же (или такой же) камерой в таком же или похожем режиме. Тестовое изображение может быть просто другим изображением из той же серии, что и исходное, но содержащим однородные области, пригодные для анализа. Вы можете подготовить тестовое специальное изображение, используя калибрационную цель, которая создана специально, чтобы обеспечить несколько областей с различной яркостью и лишенных деталей. Для подробностей обращайтесь к разделу использование калибрационной цели..

Для открытия тестового изображения нажмите [image] (кнопка Open test image… (открыть тестовое изображение)) на панели инструментов или выберите пункт меню File | Open Test Image…. Тестовое изображение заменит исходное только на закладке Device Noise Profile (профиль устройства) для создания профиля.

Или

Вставьте тестовое изображение из буфера обмена Windows или перетащите его из другого приложения в просмотр изображения на закладке Device Noise Profile.

3. Выделите найденные однородные области изображения.

Используйте мышь для выбора однородной области изображения: нажмите левую кнопку мыши, тащите мышь для выделения и отпустите кнопку.

Выделенная область должная быть не менее 60x60 точек, при этом рекомендуемый размер 100x100 точек и более. Рамка выделенной области изменит свою толщину в зависимости от размера области. Когда Вы выделяете область, статус выделения в Rough Noise Analyzer(грубый анализатор шума) динамически отражает достаточность размера области для проведения анализа.

Предупреждение

Статус выделения покажет "signal clipping!" (обрезание сигнала) если изображение в одном из каналов (R,G,B) приблизится в выделенной области к пределу динамического диапазона. Профиль устройства, созданный на такой области будет неточным. Для получения наилучших результатов, старайтесь избегать этого.

4. Грубый анализ выделенной области

Нажмите [image] (кнопка Rough Noise Analyzer (грубый анализатор)) в группе Rough Noise Analyzer или выберите пункт меню Profile | Build Using Selected Area.

Программа измерит характеристики шума устройства на основании выделенных однородных областей. Для создания грубого профиля устройства, Вам достаточно выполнить этот анализ один раз.

5. Описание имени устройства и режима работы устройства.

Используйте поля ввода Device name(имя устройства) и Device mode (режим работы устройства) га панели Device Noise Profile (профиль устройства).

Здесь Вы можете указать используемую модель устройства (например, "Olympus C5050Z").

Также, Вы можете описать режим устройства – указать параметры, использованные при получении изображения. Например, это может что-то из следующего:

o        ISO: 200

o        Компрессия: 5 bits/pixel

o        Выдержка: 1/80s

o        Экспозиционная поправка: 0.0 eV

o        Баланс белого: По умолчанию

Neat Image может автоматически заполнять поля Device name и Device mode в профиле. Если EXIF – данные доступны в исходном изображении, то программа может извлечь их.

Для этого используйте кнопку EXIF->Profile на панели инструментов или пункт меню Profile | Copy EXIF Data to Profile.

О именах устройства и режимах работы устройства

Рекомендуем указывать эти детали, для сохранения информации об устройстве и режимах в соответствующем профиле. Это важно, поскольку характеристики шума любых двух устройств могут сильно отличаться. Точно так же одно и то же устройство в разных режимах может производить существенно разный шум. Поэтому лучше использовать отдельные профили для каждого устройства и режима с целью предотвращение неточной фильтрации и артефактов. Имя устройства и описание режима работы поможет Вам при ручном сопоставлении исходного изображения и профиля.

Автоматическое сопоставление профиля использует поля EXIF изображения, а не поля Device name и Device mode, поэтому для автосопоставления в их заполнении нет необходимости. Однако, их заполнение нужно как для четкости понимания, так и для случаев, когда в исходном изображении отсутствуют EXIF - данные (в этом случае Вам потребуется ручное сопоставление профиля на основании полей Device name и Device mode).

О кросс-использовании профилей

Естественно, что всегда лучше создать новый профиль устройства на основании исходного изображения, поскольку такой профиль лучше соответствует характеру шума в конкретном изображении Тем не менее, профиль устройства может быть использован для обработки множества изображений, полученных с одного и того же устройства, работающего в том же или похожем режиме. Когда такое кросс-использвание профиля имеет место, надо принимать во внимание несколько параметров устройства.

Скорее всего, два изображения будут получены при различных или слегка отличных условиях (режим устройства, условия съемки), поэтому характеристики шума будут отличаться. В таблице ниже приведены параметры режима работы (для цифровых камер), влияющие на характеристики шума (от наиболее влияющих к наименее):

ISO | 50, 100, 200, 400, и т.д. – зависит от камеры | Более высокое ISO производит больше шума.
Корректировка резкости | Low(низкая), Normal(нормальная), High(высокая), и т.д. – зависит от камеры | Встроенная в камеру корректировка резкости делает шум более интенсивным. Отказ от ее использования обеспечивает меньший уровень шума.
Сжатие | 1:1 (или Uncompressed(несжатый)), 1:5 (или Fine(прекрасный)), 1:10 (или Normal(нормальный)), 1:20 (или Basic(базовый)), и т.д. или 2 bits/pixel, 4 bits/pixel, и т.д. – зависит от камеры | Сильное JPEG-сжатие как правило дает больше JPEG-артефактов и разрушает элементы изображения, включая шум. Слабое сжатие сохраняет детали изображения в том числе и шум, производимый сенсором. Предпочтительнее использовать самую низкую степень сжатия для получения лучших результатов фильтрации.
Разрешение | 1:1 (исходное разрешение, например 1600x1200), 1:2 (уменьшенное в камере, т.е. 800x600), 2:1 (цифровое увеличение, 2x), и т.д. | Внутренняя интерполяция в камере (как уменьшение, так и увеличение – digital zoom) изменяет многие характеристики шума.
Баланс белого | Солнечно, Облачно, Лампы накаливания, Лампы дневного света, и т.д. – зависит от камеры | Баланс белого слегка изменяет характеристики шума (в основном цветовой шум).

Если два изображения получены в одинаковых или очень близких условиях (большинство из данных режима схожи) , то шум в этих изображениях должен быть очень похож. Если Вы создадите профиль, Используя одно из этих изображений, то Вы можете использовать этот профиль для фильтрации обоих изображений с хорошим результатом.

Если же условия съемки различны, то шум двух изображений будет существенно отличаться. В этом случае кросс-использование профиля не рекомендуется. Создайте новый профиль шума для другого режима.

2. Точная настройка грубого профиля шума

Для более точного удаления шума полезно определить зависимость между уровнем шума и локальной яркостью различных частей изображения. Эту зависимость надо принять во внимание, если шум существенно зависит от яркости (например, если шума много в темных областях и мало в светлых).

Fine-Tuning Analyzer (точный анализатор) измеряет эту зависимость. Результаты измерения показываются эквалайзером профиля. Эквалайзер имеет 9 регуляторов которые отражают диапазон яркостей от самой темной до самой светлой для каждого сенсора (R, G, B) устройства.

Значения регуляторов соответствуют предполагаемым уровням шума в различных диапазонах яркостей относительно грубого профиля. Положительные значения отражают больший уровень шума и Neat Image предполагает, что большее количество элементов являются шумами. Отрицательные значения отражают более низкий, по отношению к грубому, уровень шума и Neat Image считает, что меньшее количество элементов изображения в соответствующем диапазоне яркостей являются шумами.

Точный анализ может быть как ручным, так и автоматическим. Первым рассмотрим автоматический метод. Затем разберемся с ручным методом для детального понимания процесса и результата.

Для автоматической точной настройки грубого профиля

1. Разрешите точный анализатор.

Разрешите точный анализатор отметкой на [image] в группе Fine-Tuning Analyzer.

2. Примените Автоматический точный анализатор.

Нажмите [image] (кнопка Auto Fine-Tuning Analyzer(автоматический точный анализ)) или выберите пункт меню Profile | Auto Fine-Tune.

Neat Image проанализирует все изображение и некоторые регуляторы эквалайзера примет «измеренное» положение (см. диаграмму ниже). Значения остальных регуляторов будут автоматически интерполированы функцией Auto Complete (автозаполнение) и примут статус ‘manual’(«вручную»).

Вы можете проанализировать значения эквалайзера после применения автоматического точного анализа. В большинстве случаев, в изменении положения регуляторов нет необходимости. Если Вы уверены, что это необходимо, следуйте указаниям по ручному точному анализу ниже.

Для ручной точной настройки грубого профиля

1. Найдите и выделите однородные области изображения.

Используйте мышь для выделения однородных областей изображения: Нажмите левую клавишу, выделите область и отпустите клавишу.

См. примеры однородных областей изображения.

Tразмер области может быть от 30x30 до 300x300 точек. Толщина обрамления выбранной области изменяется в зависимости от ее размера. При выборе области, статус выделения внизу Fine-Tuning Analyzer динамически отображает, какие частотные составляющие (см. что такое частота) содержатся и будут проанализированы в выделенной области: 'high'( высокие), 'high+mid'(высокие и средние), 'high+mid+low'(высокие, средние, низкие), 'high+mid+low+very low freqs'(высокие, средние, низкие, сверхнизкие частоты).

Размер изображения(точки) | Какие частотные составляющие анализируются | Оценка
200x200 - 300x300 | Высокие, средние, низкие, сверхнизкие | Отлично
100x100 - 200x200 | Высокие, средние, низкие | Хорошо
60x60 - 100x100 | Высокие, средние | Нормально
30x30 - 60x60 | Высокие | Плохо

В выбранной области будут проанализированы только имеющиеся частотные составляющие (высокие, средние, низкие и сверхнизкие). Если какая либо частотная составляющая отсутствует в области, то все данные, относящиеся к ней, будут экстраполированы. Это всегда приводит к погрешности, поэтому лучше всего определять области большего размера, содержащие все частоты.

Внимание

Статус выделения покажет "signal clipping!" (обрезание сигнала) если изображение в одном из каналов (R,G,B) приблизится в выделенной области к пределу динамического диапазона. Профиль устройства, созданный на такой области будет неточным. Для получения наилучших результатов, старайтесь избегать этого.

При выборе области, ее положение в диапазоне яркостей отражается в значениях соответствующих регуляторов эквалайзера красным шрифтоми цветовыми индикаторами снизу эквалайзера.

2. Обработать выбранную область Fine-Tuning Analyzer.

Нажмите [image] (кнопка Manual Fine-Tuning Analyzer (ручной точный анализатор)) или выберите пункт меню Profile | Fine-Tune Using Selected Area.

Результаты анализа отобразятся в эквалайзере профиля. Для однородных областей, содержащих только шум, соответствующие регуляторs примут статус 'measured' («измерено») – зеленая подсветка значения, типа [image]. Если область содержала обрезание сигнала, то соответствующие регуляторы примут статус 'inaccurate' («неточно») – красная подсветка значения, типа [image]. Если в области обнаружен неожиданно высокий уровень шума, то значения будут подсвечены оранжевым, типа [image].

Внимание

Оранжевая подсветка появляется в том случае, если шум в соответствующем диапазоне яркости чрезвычайно большой. Может быть несколько причин этого:

o                                Наиболее вероятно, что использована «плохая» область – содержащая видимые детали;

o                                Использован неправильный профиль (профиль устройства и режим не соответствуют исходному изображению или грубый профиль был создан неправильно);

o                                Шум в изображении необычен и содержит сильные вариации.

Оранжевая подсветка – предупредительный сигнал. Она не означает, что измерения будут совсем неверными. Решение в этой ситуации остается за Вами. Если необходимо, пересоздайте профиль или выберите другую область изображения для точной настройки.

Красная подсветка – сигнал заведомо неверных измерений. Вам необходимо сбросить соответствующий регулятор и отменить результаты последнего анализа (см. ниже).

3. При необходимости, сбросьте статус регулятора (необязательно).

Нажмите на цветовой подсветке регулятора (подробности о подсветке см. ниже) для сброса его статуса и значения.

Если регулятор красный (или любого другого цвета), то вы можете спокойно сбросить его и анализировать другую область изображения для получения значения. Нет необходимости сбрасывать все значения эквалайзера из-за одного неверного значения.

4. При необходимости, отмените результаты последнего анализа (необязательно).

Нажмите [image] (кнопка Undo (отменить)) или выберите пункт меню Profile | Undo Last Fine-Tuning Analysis.

Отмена последнего анализа полезна в случае, если некорректный выбор области привел к некорректным результатам анализа.

5. При необходимости, сбросьте весь эквалайзер (необязательно).

Нажмите [image] (кнопка Reset equalizer (сбросить эквалайзер)) или выберите пункт меню Profile | Reset Fine-Tuning Results.

6. Повторите шаги 1-5 на других однородных областях.

Для получения более точного профиля, Вы можете провести точный анализ на нескольких однородных областях изображения (естественно, что многократный анализ одной и той же области имеет мало смысла) Постарайтесь выбирать области так, чтобы покрыть все диапазоны яркостей во всех цветовых каналах (т.е. обеспечить подсветку всех регуляторов). Обращайте внимание на цветовую маркировку, которая отображает диапазон, покрываемый выбранной областью, типа -40%. Также используйте цветовой индикатор снизу от Fine-Tuning Analyzer как указатель, где необходимо уточнение. Если большинство значений регуляторов имеют зеленую подсветку, Вы можете прекратить процесс.

7. Установите остальные регуляторы по своему усмотрению (необязательно).

Будучи не проанализированными, регуляторы эквалайзера принимают значения по умолчанию. Вы можете оставить их таковыми или изменить, чтобы они лучше соответствовали значениям измеренных соседей.

Установите регуляторы так, как Вы считаете нужным.

Установленные вручную регуляторы принимают статус 'manual' («вручную») и желтую подсветку, типа [image].

Или

Используйте Auto Complete (автозаполнение) для автоматического изменения (интерполирования) регуляторов по измеренным данным. Для этого нажмите [image] (кнопка Auto Complete (автозаполнение)) или выберите пункт меню Profile | Auto Complete.

Использование автозаполнения крайне желательно в качестве последнего шага процесса ручной подстройки.

Ниже приводится расшифровка маркировок статуса регуляторов:

При использовании эквалайзера профиля, обращайте внимание на цветовые индикаторы для упрощения процесса подстройки. Цветные линии индикатора показывают:
- Какие регуляторы соответствуют цветам в выбранной области/ точки (используйте клавишу Shift для индикации точки);
- какие значения регуляторов отличаются от значений по умолчанию;
- какие регуляторы, возможно, имеют некорректные значения.

Ниже приводится расшифровка элементов индикатора:

Как проверить, что профиль устройства правильно настроен

Большинство регуляторов эквалайзера должны быть окрашены в зеленый и, иногда, в желтый. Цветовые индикаторы должны быть однотонными во всех позициях.

3. Сохранение точного профиля

Чтобы сохранить профиль для будущего использования.

Используйте [image] (кнопка Save device noise profile as… (сохранить профиль устройства как…), голубой диск) в группе Device Noise Profile или выберите пункт меню Profile | Save as….

В диалоговом окне Save device noise profile as, введите имя файла для сохранения профиля. Профили устройств хранятся в файлах с расширением dnp..

Сохраненные профили содержат информацию, как о грубом, так и точном анализах. Поэтому, сохраняя профиль, вы можете позже воспроизвести те же условия обработки изображения. Также, вы можете обмениваться профилями с другими пользователями Neat Image.

Профиль может, дополнительно, содержать пример изображения, использованного для создания грубого профиля. Вы можете контролировать это, используя опцию Save analyzed image area in profile (сохранять анализированные области изображения в профиль), см. Опции анализа.

Соглашение об именовании файлов

Если Вы намерены повторно использовать профиль, выбирайте для него «хорошее» имя, раскрывающее название устройства и его режим, чтобы потом легче определить профиль на основании имени файла. В качестве альтернативы, Вы можете использовать структуру каталогов для хранения профилей для множества устройств, сгруппированных по режимам работы..

Для дополнительной информации см. раздел Структурирование набора профилей.


Использование калибрационной цели

Калибрационная цель Neat Image доступна на сайте Neat Image.

1. Анализ шума цифровой камеры

Для использования калибрационной цели при подготовке тестового изображения для создания профиля устройства, выполните следующие шаги:

1. Установите камеру в режим съемки (уровень ISO, выдержка, и т.д.) для которого вы создаете профиль.

2. ВАЖНО: установите фокус на бесконечность (Вам требуется получить изображение не в фокусе).

3. Убедитесь, что калибрационная цель занимает весь кадр, сделайте снимок.

4. Откройте полученное изображение в Neat Image и создайте на нем профиль устройства:

1. Используйте центральную область для грубого анализа;

2. Используйте точный анализатор для точной подстройки профиля.

2. Анализ шума планшетного сканера

Для использования калибрационной цели при подготовке тестового изображения для создания профиля устройства, выполните следующие шаги:

1. Установите сканер в режим сканирования (разрешение, уровень освещения и т.д.) для которого вы создаете профиль.

2. Если возможно, установите сканер не в фокусе (не сфокусированные сканы предпочтительней для профилирования).

3. Сканируйте калибрационную цель

4. Откройте полученное изображение в Neat Image и создайте на нем профиль устройства:

1. Используйте центральную область для грубого анализа;

2. Используйте точный анализатор для точной подстройки профиля.

3. Анализ шума пленочного сканера

Для использования калибрационной цели при подготовке тестового изображения для создания профиля устройства, выполните следующие шаги:

1. Установите камеру в режим съемки (уровень ISO, выдержка, тип пленки,и т.д.) для которого вы создаете профиль.

2. Важно: установите фокус на бесконечность (Вам требуется получить изображение не в фокусе).

3. Убедитесь, что калибрационная цель занимает весь кадр, сделайте снимок.

4. Создайте слайд и поместите его в сканер

5. Установите сканер в режим сканирования (разрешение, уровень освещения и т.д.) для которого вы создаете профиль и сканируйте его

6. Откройте полученное изображение в Neat Image и создайте на нем профиль устройства:

1. Используйте центральную область для грубого анализа;

2. Используйте точный анализатор для точной подстройки профиля.

Как альтернативу Вы можете использовать стандартные цветные или черно-белые цели. Элементы цели должны быть однородны, черно-белые или цветные, без видимых деталей или текстуры.


Подготовка набора профилей устройства для различных режимов работы

Поскольку каждое устройство – источник изображений может работать в различных режимах, то, для того, чтобы обеспечить обработку изображений, выполненных в различных режимах, необходимо наличие набора профилей устройства, относящихся к этим режимам работы устройства. Если набор покрывает все возможные режимы работы устройства, то любое изображение, полученное от устройства, может быть обработано одним из профилей из набора.

Сначала должен быть подготовлен набор профилей для устройства. Это может сделать любой владелец устройства, поскольку он / она имеет непосредственный доступ к аппаратуре. Вы тоже можете это сделать. Чтобы помочь Вам, мы дадим несколько рекомендаций по структурированию и документированию наборов профилей, при подготовке набора профилей для вашей камеры/ сканера и т.д.. Эти рекомендации позволят Вам, а также людям, с которыми Вы пожелаете поделиться профилем (а мы советуем поделиться, поскольку это может помочь людям с такой же камерой или сканером) сделать работу с профилем более легкой. Профили можно передать команде Neat Image для публикации на сайте www.neatimage.com (см. Contacts) или просто обмениваться с другими пользователями напрямую.

1. Структурирование набора профилей

Когда Вы готовите набор профилей, например для цифровой камеры, Вы создаете профили для различных ISO, качества(уровень JPEG-сжатия), размера изображения и т.д. Благоразумно при этом поместить описание режима работы в поле строки комментария профиля (Device name, Device mode), но хорошо бы дать файлу профиля имя, включающее в себя ключевые параметры режима. Например, Профили для Olympus C5050Z могут быть названы следующим образом:

Olympus C5050Z

Olympus C5050Z JPEG ISO 100 HQ 2560x1696.dnp
Olympus C5050Z JPEG ISO 100 HQ 2560x1920.dnp
Olympus C5050Z JPEG ISO 100 SHQ 2560x1696.dnp
Olympus C5050Z JPEG ISO 100 SHQ 2560x1920.dnp
Olympus C5050Z JPEG ISO 200 HQ 2560x1696.dnp
Olympus C5050Z JPEG ISO 200 HQ 2560x1920.dnp
Olympus C5050Z JPEG ISO 200 SHQ 2560x1696.dnp
Olympus C5050Z JPEG ISO 200 SHQ 2560x1920.dnp
Olympus C5050Z JPEG ISO 400 HQ 2560x1696.dnp
Olympus C5050Z JPEG ISO 400 HQ 2560x1920.dnp
Olympus C5050Z JPEG ISO 400 SHQ 2560x1696.dnp
Olympus C5050Z JPEG ISO 400 SHQ 2560x1920.dnp
Olympus C5050Z TIF ISO 100 2048x1536.dnp
Olympus C5050Z TIF ISO 100 2288x1712.dnp
Olympus C5050Z TIF ISO 100 2560x1696.dnp
Olympus C5050Z TIF ISO 100 2560x1920.dnp
Olympus C5050Z TIF ISO 200 2048x1536.dnp
Olympus C5050Z TIF ISO 200 2288x1712.dnp
Olympus C5050Z TIF ISO 200 2560x1696.dnp
Olympus C5050Z TIF ISO 200 2560x1920.dnp
Olympus C5050Z TIF ISO 400 2048x1536.dnp
Olympus C5050Z TIF ISO 400 2288x1712.dnp
Olympus C5050Z TIF ISO 400 2560x1696.dnp
Olympus C5050Z TIF ISO 400 2560x1920.dnp

Где:

 - Папка на диске

Olympus C5050Z
- название камеры

JPEG / TIF
- формат изображения

HQ / SHQ
- качество JPEG-сжатия

ISO nnn
- значение ISO для камеры

####x####
- размер изображения

Когда профили названы так, легко найти и выбрать соответствующий профиль. Вы просто определяете режим устройства из исходного изображения (на закладке Input Image в редакторе задания в группе Input Image на правой панели) и, затем, выбираете профиль из списка профилей в папке.

Другой вариант, основываясь на структуре набора профилей, создать структуру каталогов на диске. Например, тот же набор профилей для Olympus C5050Z может быть структурирован вот так:

Olympus C5050Z

TIFF

2048x1536

ISO100.dnp
ISO200.dnp
ISO400.dnp

2288x1712

ISO100.dnp
ISO200.dnp
ISO400.dnp

2560x1696

ISO100.dnp
ISO200.dnp
ISO400.dnp

2560x1920

ISO100.dnp
ISO200.dnp
ISO400.dnp

JPEG

HQ

2560x1696

ISO100.dnp
ISO200.dnp
ISO400.dnp

2560x1920

ISO100.dnp
ISO200.dnp
ISO400.dnp

SHQ

2560x1696

ISO100.dnp
ISO200.dnp
ISO400.dnp

2560x1920

ISO100.dnp
ISO200.dnp
ISO400.dnp

Где:

- Папка на диске

Olympus C5050Z,
TIFF/JPEG,
HQ/SHQ,
####x####
- имена дисковых вложенных папок, содержащих профили устройства для соответствующего режима.

ISOnnn.dnp
- отдельный профиль устройства.

В этом случае, дерево каталогов позволяет структурированно хранить профили, что помогает при выборе профиля из набора, зная режим работы устройства из изображения. Особенно полезно это будет при выборе профиля из всплывающего меню.

Отметим, что автоматическое сопоставление профиля Neat Image прекрасно работает в обоих случаях: Вы можете иметь набор профилей как линейный список файлов в одном каталоге или вы можете структурировать файлы по подкаталогам. Это влияет только на ручной выбор профиля, автоматический работает в обеих случаях.

Если автоматическое сопоставление профиля недоступно (например, при отсутствии EXIF- данных), то Вам придется использовать ручное сопоставление. Поэтому, мы рекомендуем структурировать профили по одному из методов, приведенных выше, чтобы облегчить ручной выбор.

2. Документирование набора профилей

Даже при использовании текстовых комментариев внутри профиля устройства и детальных имен файлов профилей, мы советуем документировать набор профилей обычным текстовым файлом, содержащим следующие моменты:

· Автор набора профиля, дата анализа

· Название устройство, версия прошивки

· Режимы устройства, профилированные в наборе

o   Параметры режима, которые изменялись в наборе

o   Параметры режима, которые неизменны во всех профилях набора

· Пост-обработка (после получения изображения и перед Neat Image)

Вот пример подобного описания:

Профили для Olympus C5050Z

Созданы John Smith, November 19, 2003

Набор профилей для изображений TIFF и JPEG камеры Olympus C5050Z.
Профили созданы с использованием калибрационной цели (http://www.neatimage.com/testtarget.html) для следующих форматов файла и размеров изображения:

TIFF: 2048x1536, 2288x1712, 2560x1696, 2560x1920
JPEG HQ: 2560x1696, 2560x1920
JPEG SHQ: 2560x1696, 2560x1920

Для каждого формата и размера сделаны снимки с различными ISO (100, 200 и 400), использованные для создания профиля.

Резкость, контрастность и насыщенность в камере выставлены по умолчанию. Встроенное понижение шума выключено.
Баланс белого установлен на дневное освещение (daylight).

Пост обработка не применялась – снимок калибрационной цели напрямую передавался в Neat Image для создания профиля.

Такой вариант описания поможет Вам описать любой набор профилей, а также поможет оценить результат Вашей работы другим людям, к которым попадет профиль.


Component Viewer

Component Viewer предназначен для детального исследования как частотных, так и цветовых составляющих изображения. Анализ составляющих и масок фильтрации могут быть полезны для быстрогно и легкого поиска оптимальных настроек фильтра.

· Работая с фильтром, включите окно Component Viewer нажатием на [image] (кнопка Component Viewer on/off) на панели инструментов или выбором пункта меню View | Component Viewer. Появится окно, отражающее составляющие выделенной области изображения (о выделении см. в Filtration Job Editor).

Проанализируйте отдельные составляющие , а также маски фильтров для каждого цветового и частотного канала (используйте переключатели вверху Component Viewer). Для переключения на маски фильтра нажмите [image] (кнопку Show filtration masks (показать маски фильтрации)). Для переключения между исходным и фильтрованным изображением (или элементом изображения) просто нажмите на одном из изображений в Component Viewer.

 Красные маски показывают области, где применена стандартная (агрессивная aggressive) фильтрация шума(см верхнюю левую часть изображения справа). Измените настройки фильтра (уровни шума) Adjust noise filter settings (noise levels) так, чтобы красные маски покрывали все, лишенные интереса, области. Не допускайте любому шуму остаться непокрытым этими масками.
Зеленые маски показывают были определены важные детали изображения и применен специальный тип фильтрации шума. Этот тип фильтрации более «деликатен», чем стандартный; он используется для сохранения видимых деталей. Голубые маски отражают области изображения, где применен фильтр резкости.


Выбор вариантов (Variant Selector)

Выбор вариантов предназначен для сравнения различных вариантов фильтрации, примененных к выбранной области изображения. Когда Вы последовательно изменяете настройки фильтра, Вы получаете несколько возможных вариантов фильтрации. Для выбора лучшего из этих вариантов используйте Выбор вариантов (Variant Selector).

· · Включите Выбор вариантов нажатием на [image] (кнопка Variant Selector on/off (Выбор вариантов включен/выключен)) на панели инструментов или выберите пункт меню View | Variant Selector. Появится окно в котором можно добавить, отсортировать, удалить и выбрать варианты.

· Для добавления варианта фильтрации в Выбор вариантов, выберите область исходного изображения и предоставьте Neat Image подготовить предварительный просмотр результата фильтрации этой области. Обычно это делается автоматически Как только предварительный просмотр готов, этот новый вариант будет добавлен в Выбор вариантов. Это произойдет, если отмечена опция Автоматического добавления варианта (Auto add variants) в окне Variant Selector. Для ручного добавления нового варианта, нажмите [image] (кнопка Add new variant (добавить новый вариант)).

Если Вы измените любую настройку фильтра, то еще один вариант будет подготовлен и добавлен Neat Image в Выбор вариантов.

· В списке вариантов Вы можете нажать на любой из них для просмотра результатов фильтрации в окне просмотра изображения. Нажмите на изображение для временного переключения на нефильтрованное изображение. Перейдите на другой вариант (с помощью мыши или клавиш курсора) для сравнения результатов фильтрации.

· Нажмите [image] и [image] (кнопки Move variant up / down (передвинуть вариант вверх / вниз)) или перетащите варианты в списке для их сортировки (например, разместите лучшие варианты сверху списка, для удобства их сравнения).

· Нажмите [image] (Кнопка Delete variant (удалить вариант)) или клавишу Del для удаления выбранного варианта (вариантов) из списка.

· Нажатие [image] (кнопка Select variant (выбрать вариант)) или двойное нажатие мыши выбирает вариант как лучший и устанавливает его в фильтр (изменяет настройки фильтра в соответствии с вариантом).


Потоковая обработка

Neat Image может автоматически обрабатывать несколько изображений. Для использования этой возможности, создайте несколько заданий на фильтрацию, поместите их в очередь фильтрации (Filtration Queue) и укажите Neat Image последовательно обработать задания.

Вы также можете создать новое задание, в момент, когда существующее задание обрабатывается в фоновом режиме. Возможно создание нескольких заданий сразу (пакет-batch) для фильтрации множества изображений с идентичными параметрами фильтрации. Вы можете изменить параметры фильтрации любого задания в любое время.

В этом разделе мы детально разберемся, как вы можете использовать эти свойства Neat Image.

При чтении этого раздела, убедитесь, что выключена опция приложения Auto create new job at startup (автоматическое создание нового задания при запуске) (пункт меню View | Options…). Если эта опция включена, то при запуске приложения вместо окна очереди фильтрации (Filtration Queue) появится окно редактора задания (Filtration Job Editor). Эта опция включена по умолчанию, чтобы сделать освоение программы более легким.

· Окно очереди фильтрации

· Создание новых заданий на фильтрацию

· Редактирование заданий на фильтрацию

· Удаление заданий

· Организация очередей и задания на удержании

· Запуск и остановка очереди заданий

· Сохранение конечных изображений


Окно очереди фильтрации

Когда вы запускаете Neat Image, открывается окно очереди фильтрации (Filtration Queue) (вам надо снять опцию Auto create new job at startup (автоматическое создание нового задания при запуске) в окне опций (Options)).

Это окно содержит саму очередь (в левой части), набор средств для создания, редактирования, удаления, запуска и остановки заданий (на панели инструментов), и панель справа с подробной информацией об очереди в целом и отмеченном отдельном задании из очереди.


Создание нового задания на фильтрацию изображения

Neat Image выполняет задания на фильтрацию последовательно для каждого изображения в задании, применяя к нему заданные установки. Одиночное задание на фильтрацию включает в себя одно изображение и один набор установок фильтра. Вы можете создать и сконфигурировать одно или несколько заданий и указать Neat Image исполнить их.

Для создания нового задания на фильтрацию изображения

Нажмите [image] ( Кнопка Create new image filtration job – создать новое задание на фильтрацию изображения ) на панели управления или выберите пункт меню Job | New….

Новое задание будет создано. Сначала вам будет предложено выбрать исходное изображение и, затем, оно будет открыто в редакторе задания на фильтрацию - Filtration Job Editor. Там Вы сможете выбирать профиль устройства и изменять параметры фильтра точно так же, как описано ранее в главе Процесс фильтрации.

Когда изображение будет готово для обработки, не применяйте фильтрацию в редакторе задания в случае, если вы хотите обрабатывать изображения в очереди.

Когда исходное изображение, профиль и установки фильтра будут готовы, вы можете поместить задание в очередь фильтрации для обработки, используя органы управления в Queued Processing – обработка очереди.

Нажатие [image] поместит задание в конец очереди заданий Neat Image.

Вы можете также выбрать Auto save output image (Авто сохранение конечного изображения) и задать Output image file name for auto save (Имя файла конечного изображения), используя кнопку […]. В этом случае Neat Image автоматически сохранит конечное изображение в заданный файл, когда соответствующее задание в очереди заданий будет исполнено.

Neat Image может запросить месторасположение конечного файла и его параметры (например уровень компрессии JPEG). По умолчанию предлагается последний использованный уровень JPEG-сжатия.

Когда выбрано Auto save (авто сохранение), Вы дополнительно можете задать автоматическое удаление задания из очереди(Auto delete completed job) в случае его завершения и успешного сохранения результата.

Если вы не хотите, чтобы задание было исполнено в очереди, нажмите клавишу Esc или выберите пункт меню File | Put Job to Queue. Задание будет помещено в очередь удержания до тех пор, пока Вы не укажете Neat Image его исполнить вручную.

Для создания нескольких заданий на фильтрацию

· Нажмите [image] (кнопка Create many filtration jobs at once - создания нескольких заданий) на панели инструментов или выберите пункт меню File | Batch….

Появится окно Batch (пакет), где Вам будет дана возможность выбора файлов изображений для обработки. Также вы сможете выбрать профиль устройства и предустановки фильтра, которые должны использоваться при обработке выбранных изображений.

· [image] Нажмите [image] для добавления нового файла изображения в список.

или

Нажмите [image] для выбора всех изображений в папке. В список будут добавлены все изображения, как в выбранной папке, так и во вложенных в нее папках.

· Используйте [image] (голубой диск) или всплывающее меню для выбора профиля устройства, который будет применен к изображениям в списке.

Или вместо этого, отметьте Auto match profiles (автоматический поиск профиля) для того, чтобы Neat Image попытался самостоятельно найти наиболее подходящий профиль для каждого изображения в списке.

· Используйте [image] (розовый диск) или всплывающее меню для выбора предустановок фильтра для всех изображений в списке.

· Задайте тип конечного изображения в выпадающем списке: 8/24 bits, 16/48 bits, ил Match input(Совпадает с входным).

· Выберите желаемые «авто» - действия, которые должны быть применены ко всем заданиям в очереди:

o        Auto start processing – для автоматического запуска заданий в очереди

o        Auto fine-tune profiles – для автоматического применения точной настройки профиля для каждого задания

o        Auto save output images – для автоматического сохранения конечных изображений завершенных заданий

o        Auto delete completed jobs – для автоматического удаления завершенных заданий

· Выберите формат конечных файлов: TIFF, JPEG или BMP (только в случае, если выбрано Auto save output images (автоматическое сохранение конечных изображений)).

· Нажмите [image] для добавления нового задания на фильтрацию в очередь.

В этот момент Neat Image может Вас попросить указать месторасположение конечных файлов на диске и отдельных параметров сохранения (например, степени JPEG – сжатия).

Затем несколько заданий на фильтрацию будут созданы в очереди. Эти задания начнут немедленно исполняться, в случае, если установлен автозапуск обработки (Auto start processing).

Для создания одного или нескольких заданий на фильтрацию с использованием drag and drop

Перетащите файлы изображения из другого приложения в окно Filtration Queue (Очередь фильтрации). Neat Image автоматически создаст задания на фильтрацию для каждого изображения, используя Job Defaults (значения по умолчанию для задания), определенные в Options(опции).


Редактирование заданий на фильтрацию изображений

Если Вам необходимо изменить какие либо параметры фильтрации задания на фильтрацию из очереди, то это возможно в любой момент. Это относится ко всем заданиям в очереди, за исключением исполняющегося в текущий момент. Для редактирования исполняющегося задания, Вам необходимо перевести его на удержание, используя клавишу [image].

Для редактирования существующего задания

Выберите задание в очереди и нажмите [image] (клавишу Edit selected filtration job – редактирование выбранного задания) или выберите пункт меню Job | Edit….

Откроется окно редактора задания (Filtration Job Editor), где вы можете изменить его параметры: Исходное изображение, профиль устройства, настройки фильтра. Все изменения делаются в соответствии с описание в главе Процесс фильтрации.

Когда задание будет готово для исполнения, поместите его обратно в очередь, используя органы управления в Queued Processing (обработка очереди).

Для изменения профиля для выбранного задания в очереди

Выберите задания в очереди и используйте всплывающее меню Device noise profile (профиль устройства) в Filtration Job (задание на фильтрацию) (или выберите пункт меню Job | Set Profile) для выбора желаемого профиля.

Для изменения предустановок фильтра для выбранных заданий в очереди

Выберите задания в очереди и используйте всплывающее меню Filter preset (предустановки фильтра) в Filtration Job (задание на фильтрацию) (или выберите пункт меню Job | Set Preset) для выбора желаемых предустановок.


Удаление заданий на фильтрацию

Для удаления существующего задания на фильтрацию

Выберите в очереди одно или несколько заданий на фильтрацию, которые Вы намерены удалить и нажмите [image] (Кнопку Delete selected filtration job- удалить выбранные задания) или выберите пункт меню Job | Delete.


Организация очередей и задания на удержании

Задание на фильтрацию в очереди исполняется по мере готовности (т.е. исходное изображение и профиль устройства определены), за исключением, если Вы не перевели его в удержание. Будучи переведенным на удержание, задание не исполнится до тех пор, пока Вы явно не внесете его в очередь.

Для внесения задания в очередь

Выберите в списке одно или несколько заданий на фильтрацию, которые Вы хотите исполнить, и нажмите [image] (кнопка Queue selected job (внести задания в очередь)) или выберите пункт меню Job | Queue.

Выбранные задания примут статус 'queued' (в очереди) и будут обработаны, когда придет их время.

Для перевода заданий на удержание

Выберите в списке одно или несколько заданий на фильтрацию, которые Вы хотите перевести на удержание, и нажмите [image] (кнопка Put selected job on hold (перевести задания на удержание)) или выберите пункт меню Job | Hold.

Выбранные задания примут статус 'on hold' (на удержании) и не будут обработаны.


Запуск и остановка очереди фильтрации

Вам может потребоваться полная остановка (и затем старт снова) очереди фильтрации Это можно сделать, используя органы управления в Filtration Queue.

Для остановки очереди фильтрации

Нажмите [image] для остановки обработки заданий в очереди фильтрации.

Для запуска очереди фильтрации

Нажмите [image] для запуска обработки заданий в очереди фильтрации.


Сохранение конечных изображений

Когда задание в очереди закончено, Вы, как правило, захотите сохранить результат Это может быть сделано в Filtration Job Editor (вы можете использовать кнопку Edit для его открытия) или напрямую из окна Filtration Queue – очереди фильтрации.

Для сохранения конечного изображения задания на фильтрацию

Нажмите [image] (Кнопка Save output image as – сохранить конечное изображение как…).

Вы можете сохранить конечные изображения более чем одного задания, используя эту кнопку. Выберите несколько завершенных заданий и нажмите эту кнопку для сохранения нескольких конечных изображений сразу.


Инсталляция plug-in в редактор изображений

Для инсталляции Neat Image plug-in для…

· … Adobe Photoshop / Photoshop Elements / ImageReady

o   Метод № 1 (традиционный):

Скопируйте файл NeatImage.8bf из директории, куда установлен Neat Image (как правило, C:\Program Files\Neat Image 3.0 Pro Plus\) в директорию Plugins или Plug-ins внутри папки Photoshop / Photoshop Elements / ImageReady.

Затем перезапустите редактор и Вы обнаружите Neat Image plug-in в меню Filter(Фильтр), в подменю ABSoft.

o   Метод № 2 (более легкий, доступный для Photoshop 7.0, CS):

В Photoshop идите в пункт меню Edit | Preferences | Plug-ins and Scratch Disks (Правка|Свойства|Плугины) и установите директорию дополнительных плугинов (Additional Plug-ins Directory) на директорию, в которую установлен Neat Image (как правило, C:\Program Files\Neat Image 3.0 Pro Plus\).

Затем перезапустите редактор и Вы обнаружите Neat Image plug-in в меню Filter(Фильтр), в подменю ABSoft.

· … Jasc Paint Shop Pro

o   Откройте меню File(Файл) , выберите Preferences | File locations | Plug-ins (PSP8), Preferences | File locations (PSP7) или Preferences | Plug-in Filters (PSP4-6) и выберите папку в которую установленNeat Image. Нажмите OK и Neat Image plug-in will появится в подменю Plug-in Filters меню Effects.


Использование plug-in для обработки изображений

Plug-in Neat Image может быть вызван из редактора изображений, для обработки выделенной части одного слоя или одного канала изображения. Этот подраздел описывает ключевые шаги использования plug-in Neat Image. Эти шаги очень схожи с аналогичными, описанными в процессе фильтрации для не plug-in версии фильтра.

ШАГ I. Вызовите plug-in из редактора изображения

В редакторе изображения выделите слой (или канал) изображения, которые должны быть обработаны. В этом слое (канале) выделите оласть, которая должна быть отфильтрована. Весь слой (канал) будет обработан в случае отсутствия выделения.

Вызовите Neat Image plug-in, используя стандартный способ вызова plug-in-ов для Вашего редактора:

· Для Adobe Photoshop / Photoshop Elements / ImageReady

Выберите пункт меню Filter | ABSoft | Neat Image…

· Для Jasc Paint Shop Pro

Выберите пункт меню Effects | Plug-in Filters | ABSoft | Neat Image…

ШАГ II. Подготовка профиля устройства

Подготовка профиля устройства выполняется тем же образом, что и для обычной версии Neat Image. См. ШАГ II. Подготовка шумового профиля устройства.

ШАГ III. Настройка установок фильтра

Выполняется тем же образом, что и для обычной версии Neat Image. См. ШАГ III. Настройка установок фильтра

ШАГ IV. Применение фильтра

Для применения фильтра к изображению

Нажмите [image] (Кнопка Apply (применить) на панели инструментов закладки Noise Filter Settings (установки фильтра шума)) или выберите пункт меню Filter | Apply.

Окно plug-in закроется и начнется процесс фильтрации. Обработка может занять несколько минут (в зависимости от скорости процессора компьютера и размера изображения (или выделенной области). В процессе обработки редактор отображает индикатор прохождения фильтрации.

Plug-in Neat Image автоматически сохраняет профиль устройства и предустановки фильтра как RecentProfile и RecentPreset. Это позволяет еще раз применить plug-in (в PhotoShop используйте комбинацию клавиш Ctrl+F) с теми же установками без повторения шагов II-III. Также, вы можете открыть plug-in вручную и продолжить работу с последними использованными параметрами.


Использование plug-in в последовательностях действий Photoshop

Plug-in Neat Image может быть использован в последовательностях действий Photoshop вместе со стандартными фильтрами Photoshop. Plug-in имеет два параметра, когда используется в последовательностях: Profile (профиль) и Preset (предустановки). Параметр Profile указывает Neat Image, какой профиль устройства должен быть использован при работе. Параметр Preset определяет набор настроек, используемый фильтром.

Когда Вы записываете последовательность, использующую Neat Image, то, работая с Neat Image вы можете выбрать любой профиль и набор предустановок, сохраненных на диске, и в последовательности действий Photoshop автоматически будут приняты эти параметры. При любом последующем запуске последовательности, эти профиль и предустановки будут считаны с диска. Поэтому, вы должны позаботится о сохранности профиля и предустановок, используемых в последовательности. Если Вы хотите распространять эту последовательность, то вместе с ней Вы должны распространить как профиль, так и предустановки.


Опции программы

Используйте пункт меню View | Options… для открытия диалогового окна Options (Опции).

Neat Image имеет несколько опций, которые Вы можете изменять для настройки поведения программы. Ниже приведены описания деталей этих опций.

· Основные опции

· Значения по умолчанию задания

· Опции анализа

· Опции профиля

· Опции фильтрации

· Опции папок


Основные опции

Show splash screen at startup (показывать заставку при старте программы)

Эта опция управляет появлением заставки (картинки желтого цветка) при старте программы.

Auto create new job at startup (автоматическое создание нового задания при старте)

Когда эта опция выбрана, при старте программы появится окно редактора задания (Filtration Job Editor), вместо редактора очереди(Filtration Queue), что может быть полезно, Если вы обрабатываете отдельные изображения, не используя окно очереди.

Эта опция по умолчанию отмечена, чтобы сделать начальную работу с программой легче.

Мы предлагаем Вам выключить эту опцию, если Вам приходится много работать с очередями заданий.

Show hints over interface controls (показывать подсказки для органов управления)

Эта опция позволяет включать и выключать подсказки. Эти подсказки высвечиваются когда курсор мыши располагается над конкретным элементом управления.

Double buffer image viewers (двойная буферизация просмотра изображения)

Эта опция определяет механизм буферизации просмотра изображения. Двойная буферизация обеспечивает лучшее качество отображения в ущерб скорости. Выключите эту опцию на медленных машинах для повышения быстродействия.

Allow overwriting existing image files (разрешить перезапись существующих файлов)

Включив эту опцию, Вы разрешите Neat Image перезаписывать существующие файлы, в случае, если установлено автоматическое сохранение конечных файлов (при поточной обработке).

Preserve EXIF data in output images (сохранять EXIF информацию в конечном изображении)

Включите эту опцию, чтобы указать Neat Image сохранять поля EXIF данных, копируя их из исходного изображение в конечное. Отметим, что копирование полей EXIF данных в конечное изображение не всегда возможно. Это зависит как от типа исходного, так и от типа конечного файла. EXIF копируется в следующих комбинациях типов исходного и конечного фалов: JPEG->JPEG, JPEG->TIFF, and TIFF->TIFF.

Enable multiprocessor support(разрешить поддержку многопроцессорных систем)

Включите эту опцию, чтобы разрешить Neat Image использовать все доступные процессоры в многопроцессорных системах или на процессорах с технологией HyperThreading. Если опция включена, то Neat Image обрабатывает два или более заданий из очереди одновременно.


Установки по умолчанию для заданий

Default color space (цветовое пространство по умолчанию)

Эта опция определяет цветовое пространство, выбираемое по умолчанию при создании нового задания (если отсутствует профиль по умолчанию; см. Default device noise profile ниже). В случае необходимости, позже в процессе работы, Вы всегда можете изменить рабочее цветовое пространство; эта опция просто определяет выбор по умолчанию.

Рабочее цветовое пространство – это цветовое пространство, которое используется Neat Image для анализа обрабатываемого изображения. На текущий момент доступно три цветовых пространства: RGB, YCrCb JPEG, и YCrCb Symmetric. Для большинства изображений мы рекомендуем использовать YCrCb JPEG (для цветных изображений) и YCrCb Symmetric (для монохромных).

Замечание: Рабочее цветовое пространство не оказывает влияния на цветовые профили (ICC profiles) вложенные в файл изображения.

Default output bitdepth (глубина цвета по умолчанию)

Эта опция определяет глубину цвета по умолчанию для обрабатываемых фильтром изображений. Например, если исходное изображение имело глубину цвета 8/24 бит и конечная глубина цвета установлена 16/48 бит, то исходное изображение будет преобразовано в 16/48 бит, обработается фильтром, и конечное изображение будет 16/48 бит. Если выбрано 'match input' (соответствовать исходному) , но конечное изображение будет иметь глубину цвета равную исходному..

Default device noise profile (профиль устройства по умолчанию)

Профиль устройства по умолчанию открывается автоматически Neat Image при создании нового задания на фильтрацию Задайте имя и месторасположение файла, содержащего этот профиль, используя кнопку […].

Эта опция может вам понадобиться, если Вы часто используете один и тот же профиль. Любой профиль может быть установлен профилем по умолчанию.

Default filter preset (установки фильтра по умолчанию)

Установки фильтра, автоматически загружаемые Neat Image при создании нового задания на фильтрацию Задайте имя и месторасположение файла, содержащего эти настройки, используя кнопку […].

Эта опция может вам понадобиться, если Вы часто используете одни и те же настройки. Любой файл настроек может быть установлен в качестве настроек по умолчанию.

Auto save output image (автоматическое сохранение конечного изображения)

Отметьте эту опцию, если Вы хотите , чтобы опция auto save output image в окнах Filtration Job Editor (редактор задания) и Batch (Пачка) была по умолчанию отмечена.

Auto delete completed job (автоматическое удаление завершенных заданий)

Отметьте эту опцию, если Вы хотите , чтобы опция auto delete completed job в окнах Filtration Job Editor (редактор задания) и Batch (Пачка) была по умолчанию отмечена.

Output file name suffix (суффикс конечного файла)

Определяет строку, добавляемую к имени конечного файла по умолчанию.


Опции анализа

Combination of last fine-tuning analyses (комбинирование результатов последних анализов)

Опция определяет порядок комбинирования результатов нескольких анализов, приходящихся на один и тот же диапазон яркости, в эквалайзере профиля устройства.

Для того, чтобы определить зависимость между уровнем шума и яркостью в изображении необходимо проанализировать множество однородных областей. Каждый отдельный анализ определяет зависимость в некотором ограниченном диапазоне значений яркости. Эквалайзер профиля отражает полученные зависимости набором регуляторов, соответствующих определенному диапазону яркости для каждого канала цвета RGB.

Изначально все регуляторы находятся в положениях по умолчанию. При анализе их положения изменяются в соответствии с обнаруженными характеристиками шума.

Существует вероятность, что различные анализы влияют на один и тот же диапазон яркости и изменяют один и тот же регулятор. В этом случае, поведение регулятора определяется опцией Combination of last fine-tuning analyses:

· Take the maximum value (брать максимальное значение) (рекоментуется)
- Эквалайзер устанавливает регулятор в максимальное из двух последних анализов (агрессивная фильтрация, убирается максимальное количество шума);

· Take the minimum value (брать минимальное значение)
- Эквалайзер устанавливает регулятор в минимальное из двух последних анализов (предохраняющая фильтрация, минимальные изменения в изображении);

· Take the average value (брать среднее значение)
- Эквалайзер устанавливает регулятор в среднее значение из двух последних анализов;

· Take the last value (брать последнее значение)
- Эквалайзер устанавливает регулятор по результатам последнего анализа.

Save analyzed image area in profile (сохранять проанализированные области изображения в профиль) (файл *.dnp)

Включите эту опцию для сохранения Neat Image проанализированных областей в файл профиля устройства (файл *.dnp). Это увеличит размер файла профиля, но при этом обеспечит совместимость с будущими версиями программы (планируется, что Neat Image будет иметь возможность пересоздавать профиль устройства, используя сохраненные области).


Опции сопоставления профилей

Matching device noise profile folder/directory (директория для сопоставляемых профилей)

Определяет каталог, где Neat Image должен искать профили устройства для поиска наиболее подходящего исходному изображению. Это должна быть родительская папка для всех тех, где расположены профили, участвующие в процессе автоматического сопоставления.

По умолчанию, используется каталог PROFILES директории, куда установлен Neat Image.

Matching parameters priorities (приоритет сопоставления параметров)

Для автоматического сопоставления профиля исходному изображению, Neat Image сравнивает параметры устройства ил исходного изображения и из анализируемого профиля. Различные параметры обычно имеют различный приоритет. Используя настройки, Вы можете определить приоритеты для таких параметров как Input device(устройство-источник), ISO rate(чувствительность), Compression(степень сжатия), Exposure(экспозиция):

· Match – значения параметра должны точно совпадать;

· High – это весьма важный параметр, его значения должны быть почти равны или совпадать;

· Low – желательно, чтобы значения параметров были почти равны или совпадали;

· Ignore – значения параметра непринципиальны.

Auto match on image open (автоматическое сопоставление при открытии изображения)

Если опция выбрана, то при открытии изображения происходит автоматический поиск наиболее подходящего профиля устройства.


Опции фильтрации

Audible indication (звуковое оповещение)

Neat Image имеет простую систему звукового оповещения.

Отметка на when filtration jobs are processed (когда обработано задание) разрешает/запрещает периодические звуки во время процесса фильтрации. Это может помочь вам контролировать программу во время обработки заданий.

Отметка на when all filtration jobs are done (когда все задания выполнены) разрешает/запрещает одиночный звуковой сигнал для оповещения об окончании процесса фильтрации.

Filtration Job Editor (Редактор задания на фильтрацию)

Auto minimize (автоматическое сворачивание) – свернуть окно редактора во время фильтрации. Этот пункт имеет две цели: первая – возможное ускорение процесса фильтрации и сэкономить память, и, второе, убрать окно редактора на время обработки, чтобы не мешать Вам.

Auto restore (автоматическое восстановление) - восстанавливать окно редактора по окончании процесса фильтрации.

Filtration Queue window (Окно очереди фильтрации)

Auto restore (автоматическое восстановление) - восстанавливать окно по завершении всех заданий.

Filter process priority (приоритет процесса фильтрации)

Используйте эту опцию для изменения приоритета процесса фильтрации в многозадачном окружении:

· Idle — самый низкий приоритет, фильтрация «уступает дорогу» ,при необходимости, любому другому приложению.

· Below — приоритет ниже нормального - обеспечивает нормальную производительность другим приложениям. Это может несколько замедлить работу Neat Image, но позволяет Вам нормально работать с другими программами, особенно если Вы используете медленный компьютер.

· Normal — нормальный приоритет – процесс фильтрации может слегка замедлить другие программы.

Auto recalculate preview (автоматический пересчет предварительного просмотра)

Эта опция разрешает/запрещает автоматический пересчет предварительного просмотра в редакторе задания на фильтрацию (Filtration Job Editor). Если разрешено, автоматический пересчет происходит каждый раз, когда Вы выбираете новую область изображения или изменяете параметры фильтра. Автопросмотр появляется только при использовании закладки установок фильтра шума (Noise Filter Settings ).

...every N second(s) (каждые N секунд)

Этот параметр определяет задержку между изменением параметра фильтра и перерасчетом предварительного просмотра.


Опции папок

Use independent open/save folders/directories (использовать отдельные папки для открытия и сохранения)

Эта опция позволяет использовать две различных папки, одна из которых используется для открытия файлов, а другая для сохранения. Если опция включена, тогда Neat Image помнит две папки, в противном случае только одна папка используется как для открытия, так и для сохранения изображений

Use independent folders/directories for images/profiles/presets (использовать отдельные папки для изображений, профилей и настроек)

Эта опция разрешает использование трех отдельных папок для работы с изображениями, профилями устройства и настройками фильтра. Если опция включена, тогда Neat Image помнит 3 папки, в противном случае одна папка используется для изображений, профилей, настроек.

Temporary folder/directory (Папка временных файлов)

Определяет папку, где Neat Image будет хранить временные файлы. В других приложениях она иногда называется 'scratch disk' (черновой диск).

Profile folder/directory (Папка профилей)

Определяет папку, где Neat Image будет искать профили устройства. Это должна быть родительская папка для всех подпапок с профилями устройств. В этом случае Neat Image сможет показать в сплывающем меню панели Device Noise Profile (профиль устройства) редактора задания (Filtration Job Editor) и очереди заданий (Filtration Queue) все профили, хранящиеся во всех подпапках указанной.

По умолчанию используется папка PROFILES в директории, куда установлен Neat Image.

Preset folder/directory (Папка предустановок)

Определяет папку, где Neat Image ищет предустановки фильтра. Это должна быть родительская папка для всех подпапок с профилями устройств. В этом случае Neat Image сможет показать в сплывающем меню панели Noise Filter Settings (настройки фильтра) редактора задания (Filtration Job Editor) и очереди заданий (Filtration Queue) все предустановки, хранящиеся во всех подпапках указанной.

По умолчанию используется папка PRESETS в директории, куда установлен Neat Image.


Изображения для создания профиля устройства (примеры)

Посмотрите на изображения, представленные ниже, как пример областей (хороших и плохих), выбранных для создания профиля устройства. Области, пригодные для создания профиля подсвечены зеленым, а те, что непригодны – подсвечены красным. Отметим, что пригодные для создания профиля области должны быть размером не менее 60x60 точек (лучше 100x100 точек и больше).

Ниже приводятся дополнительные комментарии, относительно областей.

Эти области могут быть использованы для создания профиля устройства, поскольку не содержат видимых деталей в всех частотных диапазонах:

– ХОРОШО, поскольку область не содержит важных деталей

– ХОРОШО, нет важных деталей (эта область из другого изображения)

Следующие области не должны использоваться для создания профиля устройства, поскольку они содержат важные детали:

– ПЛОХО, поскольку область содержит деталь: угол – пересечение стены и потолка

– НЕПРИЕМЛЕМО, поскольку область содержит множество деталей

– ПЛОХО, поскольку область содержит некоторые детали: облака (эта область из другого изображения)

См. другие примеры создания профилей устройств на сайте Neat Image.


Изображения для тонкой настройки профиля устройства

В этом разделе вы можете найти примеры частей изображений, которые могут быть использованы для точкой настройки профиля устройства в profile equalizer (выравниватель профиля):

Области большого размера

В областях, размером больше чем 100x100 точек, оцениваются высокие, средние и низкие частотные составляющие.

Примеры точно такие же, как и в случае создания профиля устройства. См. примеры создания профиля устройства.

Области среднего размера

В областях изображения, размером больше 60x60 точек, но меньше чем 100x100 точек, анализируются только высокие и средние частотные составляющие:

– ХОРОШО, поскольку эта область лишена важных деталей

– ПЛОХО, поскольку присутствует деталь в средних частотах (вертикальная линия)

– НЕПРИМЕНИМО, поскольку присутствует множество среднечастотных деталей (горизонтальные линии)

Области малого размера

В областях изображения, размером больше, чем 30x30 точек, но меньше, чем 60x60 точек, анализируются только высокие частотные составляющие:

– ХОРОШО, поскольку, хотя область содержит низкочастотные составляющие, они отбрасываются из рассмотрения из-за размеров области

– ПЛОХО, поскольку область содержит деталь в высоких частотах (вертикальная линия)

– НЕПРИМЕНИМО, поскольку область содержит много деталей

См. другие примеры тонкой настройки фильтров га сайте Neat Image.


Результаты фильтрации

Это несколько примеров работы Neat Image.

Исходное | Результат
Это фрагмент цифрового изображения, полученного с цифровой камеры Nikon CoolPix 950. Оригинальное изображение содержит видимый шум. В этом случае источником шума является сенсор камеры, установленный в режим высокой чувствительности (ISO).

Исходное | Результат
Это изображение получено с цифровой камеры Kodak DC 210. Вместе с шумом CCD-сенсора, установленного в режим высокой чувствительности, присутствует деградация изображения, вызванная JPEG компрессией. Даже если Neat Image пытается сделать такие изображения лучше, избегайте использовать сильное JPEG сжатие!

Другие примеры фильтрации на веб-сайте Neat Image.


Общие вопросы

Q: В чем отличие версий Demo, Home, Pro и Pro+ Neat Image?

A: В Demo версии запрещена часть расширенной функциональности. В частности, она не сохраняет изображения в формате TIFF and BMP и не копируем в буфер обмена (Demo версия сохраняет изображения только в JPEG). Pro+ включает plug-in версию фильтра. Для полной информации смотрите Detailed feature map.

Q: Должен ли я удалить Demo версию перед установкой Home/Pro/Pro+ версий?

A: В этом нет необходимости. Однако Вам нет нужды в Demo версии, поскольку Вы устанавливаете Home / Pro / Pro+, которые имеют всю функциональность Demo плюс дополнительные возможности. Для удаления Demo, используйте ярлык Uninstall в меню: Start menu->Programs->Neat Image Demo->Uninstall (Пуск->Программы-> Neat Image Demo->Uninstall). Вам может понадобиться вручную удалить изображения и профили, которые размещены в подпапках Image Demo.

Q: Должен ли я удалить старую версию Neat Image prior перед установкой новой?

A: Да, обычно это необходимо. Удалите старую версию Neat Image и, только после этого, устанавливайте новую версию. Это даст уверенность, что важные файлы не будут перепутаны.

Q: Вы собираетесь выпустить версии для Mac os9 или osX ?

A: Mac версия Neat Image находится в разработке.

Q: Мне кажется, что я нашел ошибку а программе. Как мне отослать отчет об ошибке ?

A: Воспользуйтесь online bug report form на сайте Neat Image; пожалуйста заполните эту форму, чтобы у нас была вся информация, необходимая для воспроизведения проблемы.

Для большей информации об ошибках программы, обращайтесь к секции Известные ошибки , а об исправленных ошибках к файлу WhatsNew.txt, поставляемому вместе с программой (также смотрите раздел История на сайте Neat Image для более свежей информации).

Q: Как насчет пакетной обработки?

A: Neat Image поддерживает пакетную обработку, начиная с версии 2.0. Смотрите раздел Потоковая обработка.

Ранние версии Neat Image (v1.x) могут использовать Neat Batch – помошник пакетной обработки (http://www.tawbaware.com/neatbatch.htm), который добавляет простейшую пакетную обработку к Neat Image. Это свободная программа, написанная Max Lyons.

Пакетная обработка также возможна с plug-in версией Neat Image через пакетный механизм Photoshop.


Вопросы по фильтрации

Q: Почему я получаю некоторые кристалловидные (crystal-like) артефакты в фильтрованном изображении?

A: Кристалловидные артефакты (причиной которых является JPEG сжатие) выглядят как тонкие линии. Избавиться от них можно, увеличив значение настройках высокочастотного канала фильтра шума.

Замечание: Присутствие большинства оcтаточных артефактов обычно является следствием использования некорректно созданного профиля устройства или использования профиля созданного для другого устройства или режима устройства.

Q: Фильтрованное изображение выглядит «пластмассовым» (plastic'). Почему?

A: Причина в слишком большом уровне фильтрации, примененном к исходному изображению. Укажите Neat Image оставить некоторое количество шума для того, чтобы результат выглядел более реалистично. Скорректируйте величину убираемого шума (например, уменьшите величину в канале Y до 50-70%).

Также, убедитесь, что профиль устройства соответствует обрабатываемому изображению. Использование несоответствующего профиля или некорректно созданного профиля может привести как к эффекту «пластмассы», так остаточным артефактам (см. предыдущий раздел).

Q: Что такое «частота»?

A: Термин «частота» используется в Neat Image для обозначения элементов изображения (как важных деталей, так и шума) определенного размера.

Высокая частота(High frequency) соответствует элементам меньшего размера. Средняя частота (Medium frequency) соответствует элементам среднего размера. Низкая частота (Low frequency) соответствует элементам большого (относительно) размера.

Смотрите примеры шума в различных частотах на закладке Noise Filter Settings (Установки фильтра шума) в редакторе задания на фильтрацию.

Q: Процесс фильтрации медленный, это нормально?

A: Это нормально, поскольку алгоритм фильтрации достаточно сложный. Мы работаем над оптимизаций для повышения производительности.

Q: Изменяется ли исходное изображение в соответствии с открытым профилем устройства?

A: Исходное изображение НИКОГДА не изменяется. Neat Image всегда создает новое конечное изображение, содержащее результат фильтрации. Конечное изображение может быть сохранено в любой файл.

Q: Как отфильтровать только цветовой шум (не яркостной шум)?

A: Когда используется цветовое пространство YcrCb, установите значение фильтрации для канала Y (в Установках фильтра шума(Noise filter settings)) в 0%. Это выключит фильтрацию яркостного (luminance) канала Y.

Q: Что такое YCrCb?

A: YCrCb – это название семейства цветовых пространств широко используемых в цифровых изображениях, телевидении, сжатии изображений (например, JPEG – сжатие хранит изображения в этом пространстве), и т.д.

В 'YCrCb', 'Y' соответствует яркостному каналу (luminance channel), 'Cr' – хроматическому каналу, покрывающему диапазон от красного до сине-зеленого, а 'Cb' – хроматическому каналу, покрывающему диапазон от голубого до желтого. Поскольку это пространство позволяет легко отделить яркостную и цветовую информацию, оно хорошо подходит для задач фильтрации шума.

Q: Когда лучше проводить фильтрацию посредством Neat Image - до или после другой обработки (например, цветокоррекции)?

A: Такие операции, как цветовая коррекция вполне безопасны с точки зрения шума, то есть они несущественно изменяют шумовые характеристики изображения. Поэтому, фильтрация до или после имеет мало отличий – при условии, что профиль устройства создан и применен на той же стадии обработки изображения. Например, не используйте профиль устройства, созданный на необработанном изображении, для фильтрации подвергшегося обработке изображения.

Некоторые цифровые камеры выполняют некоторую цветокоррекции внутри себя. Другие камеры позволяют получить доступ к необработанным (RAW) данным. Neat Image – это обычный фильтр, который может быть применен в обеих случаях. Единственным условием является использование соответствующего профиля.

С другой стороны, применение повышения резкости (sharpening) к зашумленному изображению повышает уровень шума. Лучше всего использовать фильтрацию Neat Image перед повышением резкости (включая внутреннюю камеры). Однако, фильтр резкости и фильтр шума Neat Image могут быть использованы совместно, поскольку фильтр резкости исполняется ПОСЛЕ фильтра шума.


Предотвращение «полосатости» (banding)

В некоторых случаях, при применении фильтра шума к изображению со слабыми градиентами яркости, может возникнуть эффект «полосатости». Этот эффект достаточно редок для нормальных изображений, особенно когда используется true color дисплей. Он может быть более заметен при использовании hi-color дисплеев. Это общая проблема hi-color дисплеев. Если дисплей не поддерживает достаточное количество цветов, то изображение может содержать некоторые диапазоны одинакового цвета. Обычно для маскирования этой проблемы используется размытие, сглаживание (Dithering). Исходное изображение обычно содержит некоторый шум, который дает эффект размытия. Когда Neat Image удаляет этот шум, подлежащая проблема полосатости всплывает опять. Решением проблемы является использование true color дисплеев или лучшего просмотра изображений (в hi-color), который бы применял размытие автоматически.

Для предотвращения «полосатости» попробуйте уменьшить величину понижения шума для высокочастотных составляющих изображения до 50%.


Фильтрация областей теней

В некоторых случаях предпочтительно фильтровать в изображении только области теней, оставляя области светов нетронутыми. С помощью Neat Image вы можете сделать это, используя эквалайзер профиля для ограничения или предотвращения фильтрации в светлых областях изображения.

Регуляторы эквалайзера профиля соответствуют отдельным диапазонам яркости (отдельно для каждого цветового канала) цветового пространства RGB. Положение каждого регулятора изменяет (подстраивает) параметры профиля для соответствующего диапазона яркостей. Чем ниже регулятор, тем меньший уровень фильтрации будет применен к элементам, находящимся в соответствующем диапазоне яркостей..

Поэтому, для фильтрации только теней, Вы можете вручную передвинуть «светлые» (обратите внимание на градиенты снизу от эквалайзера) регуляторы вниз. Например, сдвинуть вниз все, кроме трех «темнейших» регуляторов для каждого RGB канала.

Используя этот метод, Вы можете эффективно предотвратить фильтрацию в светлых областях изображения.

Если Вы используете plug-in версию Neat Image, то Вы можете фильтровать света/тени только с использованием средств выделения редактора. Выберите область для обработки (например, выделите тени, основываясь на низких яркостных значениях) и укажите plug-in отфильтровать ее.


Частичная фильтрация

Некоторые изображения содержат как зашумленные, так и чистые области и может оказаться предпочтительным отфильтровать только те из них, которые содержат шум. Это может быть сделано вручную комбинацией двух изображений – оригинального и фильтрованного – в редакторе изображений. Например, следующая последовательность действий может быть использована, если вы используете Neat Image:

1. Отфильтруйте исходное изображение в Neat Image (так чтобы зашумленные области очистились) и сохраните результат в новом файле;

2. Откройте этот файл в редакторе;

3. Поместите фильтрованное изображение в новом срезе (layer) сверху от исходного изображения;

4. Измените уровень прозрачности нового среза так, чтобы зашумленные области выглядели наиболее хорошо;

5. Выделите и удалите области нового среза, где фильтрация не нужна или чрезмерна (вы можете захотеть использовать средства удаления совместно с изменением прозрачности и формы выделения).


Ускорение обработки

Вы можете получить большую скорость фильтрации если один (или несколько) составляющих изображения не обрабатывается. Для запрета обработки частотных каналов установите величину понижения шума и фильтра резкости в 0%. Для запрета обработки цветового канала установить величину понижения шума в 0% и запретите фильтр резкости для этого канала.

Скорость фильтрации возрастает на 15-25% на каждую отключенную составляющую исходного изображения.


Известные ошибки

We are trying to keep bugs away from Neat Image as much as possible. Please report any bugs or problems (even those already described below) you encounter while working with Neat Image. For convenience, use the online bug report form on the Neat Image web page. Your feedback will greatly help us to improve the software and provide you with an even better imaging tool. Thank you very much in advance!

List of known issues

· Nothing so far


Планы

Текущая версия Neat Image – результат наших исследований фильтрации шума. Мы продолжаем работу над алгоримом фильтрации для повышения качества и скорости уменьшения шума. Дополнительно, мы планируем в будущем ввести новую функциональность, такую как:

· Mac версия

· Удаление тепловых точек

Please let us know if you have ideas that can make the program better. Participate in the discussion on the Neat Image message board, express your opinion, make suggestions, and ask questions. Remember, the more people that ask for a feature the more likely it is that it will be implemented.


Detailed feature map

Свойства |  |  | Версия
 |  |  | Demo | Home | Pro | Pro+
Обработка изображений | Скорость обработки |  | 100% | 100% | 100% | 100%
 | 8 bits/channel (24-bit RGB, 8-bit Grayscale) |  | + | + | + | +
 | 16 bits/channel (48-bit RGB, 16-bit Grayscale) |  | - | - | + | +
 | Альтернативные цветовые пространства (YCrCb standard (ITU 601), YCrCb symmetric, RGB) |  | + | + | + | +
Фильтрация шума | По цветовым каналам (R, G, B; Y, Cr, Cb) |  | + | + | + | +
 | По частотным каналам (High, Mid, Low, Very low) |  | + | + | + | +
Фильтрация резкости | По цветовым каналам (R, G, B; Y, Cr, Cb) |  | + | + | + | +
 | По частотным каналам (High, Mid, Low) |  | + | + | + | +
Предустановки фильтра (сохранение настроек фильтра шумов и резкости) |  |  | + | + | + | +
Исходное/конечное изображение | TIFF (uncompressed, single image/no layers) | 24-bit RGB | +/- | +/+ | +/+ | +/+
 |  | 48-bit RGB | -/- | +/- | +/+ | +/+
 |  | 8-bit grayscale | +/- | +/+ | +/+ | +/+
 |  | 16-bit grayscale | -/- | +/- | +/+ | +/+
 | JPEG | 24-bit RGB | +/+ | +/+ | +/+ | +/+
 |  | 8-bit grayscale | +/+ | +/+ | +/+ | +/+
 | BMP (uncompressed) | 24/32-bit RGB | +/- | +/+ | +/+ | +/+
 |  | 8-bit grayscale | +/- | +/- | +/- | +/-
 | Windows clipboard | 24/32-bit RGB | +/- | +/+ | +/+ | +/+
 | Drag-and-drop (из Windows Explorer – проводник) |  | - | + | + | +
 | Сохранение EXIF-данных в обрабатываемых файлах |  | - | + | + | +
Шумовые профили устройства | Создание профиля устройства для устройств-источников изображения |  | + | + | + | +
 | Соответствие профиля изображению |  | + | + | + | +
 | Повторное использование (сохранение/загрузка) профилей |  | + | + | + | +
Обработка | Очередь обработки/ |  | ограничено* | ограничено ** | полное | Полное
 | Поддержка командной строки |  | - | + | + | +
 | Версия фильтра как plug-in для Photoshop |  | - | - | - | +

* Длина очереди ограничена 2-мя заданиями.
** Длина очереди ограничена 10-ю заданиями.


Contacts

We really appreciate your opinion of Neat Image. Please let us know what you think about the program. Feel free to ask questions regarding Neat Image. To share your opinion or to receive support regarding Neat Image, use any of the following means:

E-mails

info@neatimage.com — for general inquiries

support@neatimage.com — for any inquiries regarding use of Neat Image

sales@neatimage.com — for any inquiries regarding purchase of Neat Image software

Message board

Register in Neat Image community forum, and participate in discussions on the use and development of Neat Image. Such topics are covered in the forum as:

· announcements of new and updated version of the software;

· questions about use of Neat Image;

· examples of using Neat Image with comments and suggestions;

· feedback from the users: suggestions of new features and improvements;

· polls: what OS, CPU, camera types are used with Neat Image;

· contacts and general comments.

Web page

Main location


Legal information

Copyright

Neat Image Copyright © 1999-2003 by ABSoft. All rights reserved.

License agreement

Your use of this software indicates that you accept this license agreement:

You may

Use Demo edition of Neat Image free of charge for non-commercial purposes.
Copy and distribute Demo edition of Neat Image.
Purchase a license for Neat Image Home, Pro, or Pro+ edition and become a registered user of the software.
Run one (or more, up to the number specified in your license) instance(s) of Neat Image Home, Pro, or Pro+ at a time for commercial and other purposes (for registered users only).

You may not

Sublicense, rent, lease or sell any version/edition of Neat Image or any portion of it.
Decompile, disassemble, reverse engineer or modify any version/edition of Neat Image or any portion of it.
Copy and distribute Home, Pro, or Pro+ edition of Neat Image.
Use Home, Pro, or Pro+ edition of Neat Image if you are not registered user.

Term and termination

You may terminate this license agreement at any time by returning or destroying all copies of Neat Image in your possession and notifying ABSoft. This license agreement will terminate immediately if you infringe upon ABSoft's copyrights or breach this agreement.

Disclaimer of warranty

The authors make no warranty or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "as is", and you, its user, assume the entire risk as to its quality and accuracy.

Distribution

Demo edition of Neat Image may be distributed unmodified provided any charge is to cover distribution costs only.
Demo edition of Neat Image may be placed on magazine CDs, etc. as long as ABSoft is informed.


Registration

To become a registered user and to get a fully functional edition of Neat Image (Home, Pro or Pro+ edition) you have to purchase a Neat Image license (a single- or multi-user license). That can be done through an online software shop on the Internet. Please find the detailed information in the Purchase section of Neat Image web page.

After you have purchased a Neat Image license, you will receive an e-mail from the Neat Image team with detailed download and registration instructions. These instructions will help you download Neat Image Home, Pro or Pro+ and become a registered user of the software.

By becoming a registered user of Neat Image Home, Pro or Pro+ edition you will:

1. Encourage the authors to further develop and improve Neat Image;

2. Get access to the functions of Neat Image that are disabled in the Demo edition (see the Detailed feature map);

3. Be able to use Neat Image for commercial and other purposes;

4. Get free access to updates (minor modifications) of the software;

5. Enjoy the reduced upgrade prices for major future modifications of Neat Image;

6. Receive the most attention of Neat Image support group;

7. Receive the most attention of Neat Image development group (tell us what you want in the new version).

Message from Neat Image team

By becoming a registered user you are helping us to continually improve the software. It is only possible with your support!

Become a registered user and we will make Neat Image better for YOU!


Acknowledgments

Neat Image utilizes the Intel JPEG Library.

Neat Image utilizes the openTIFF library.

Neat Image utilizes the Windows XP Theme Manager by Mike Lischke.

Thank you to all the users who have contributed to Neat Image by proposing improvements and new features.

Thanks to all the people who help us to find bugs in Neat Image.

Thank you to all the users who stimulate the development of Neat Image by their word and deed.

Image wouldn't be Neat without all of you!

Neat Image team, ABSoft